Ⅰ linux下Route 路由指令使用詳解
linux route命令 用於顯示和操作IP路由表 。
要實現 兩個不同子網之間的通信 ,需要一台連接兩個網路的路由器,或者同時位於兩個網路的網關來實現。
在Linux系統中,設置路由通常是為了解決以下問題:該Linux系統在一個區域網中,區域網中有一個網關,能夠讓機器訪問Internet,那麼就需要將這台機器的IP地址 設置為 Linux機器的默認路由 。
格式:
[root@linux ~]# route [-nee]
[root@linux ~]# route add [-net|-host] [網域或主機] netmask [mask] [gw|dev]
[root@linux ~]# route del [-net|-host] [網域或主機] netmask [mask] [gw|dev]
1、 查看相關參數:
-n :不要使用通訊協定或主機名稱,直接使用 IP 或 port number;
-ee :使用更詳細的資訊來顯示
2、增加 (add) 、刪除 (del) 路由的相關參數:
-net :表示後面接的路由為一個網域;
-host :表示後面接的為連接到單部主機的路由;
netmask :與網域有關,可以設定 netmask 決定網域的大小;
gw :gateway 的簡寫,後續接的是 IP 的數值喔,與 dev 不同;
dev :如果只是要指定由那一塊網卡連線出去,則使用這個設定,後面接 eth0 等
設置默認路由
格式:route add default gw {IP-ADDRESS} {INTERFACE-NAME}
其中,
參數{IP-ADDRESS): 用於指定路由器(網關)的IP地址;
參數{INTERFACE-NAME}: 用於指定介面名稱,如eth0。使用/sbin/ifconfig -a可以顯示所有介面信息。
例:
添加到指定網路的路由規則
格式:route add -net {NETWORK-ADDRESS} netmask {NETMASK} dev {INTERFACE-NAME}
其中
參數{NETWORK-ADDRESS}: 用於指定網路地址
參數{NETMASK}: 用於指定子網掩碼
參數{INTERFACE-NAME}: 用於指定介面名稱,如eth0。
例:
屏蔽一條路由,設置到指定網路為不可達 ,避免在連接到這個網路的地址時程序過長時間的等待
格式:route add -net {NETWORK-ADDRESS} netmask {NETMASK} reject
例:
刪除路由設置 ,參數指定的方式與route add相似。
格式:route del -net {NETWORK-ADDRESS} netmask {NETMASK} dev {INTERFACE-NAME}
格式:route del -net {NETWORK-ADDRESS} netmask {NETMASK} reject
例:
注意的是 ,直接在命令行下執行route命令來添加路由, 不會永久保存 ,當網卡重啟或者機器重啟之後,該路由就 失效 了; 要想永久保存 ,有如下方法:
1. 在/etc/rc.local里添加
2. 在/etc/sysconfig/network里添加到末尾
3. /etc/sysconfig/static-router :
any net x.x.x.x/24 gw y.y.y.y
Ⅱ 靜態路由配置命令步驟
4.2基礎配置
路由器的基礎配置
interface GigabitEthernet0/0/0
ipaddress 192.168.100.1 255.255.255.0
interface LoopBack100
ip address 100.100.100.100 255.255.255.0
interface LoopBack200
ip address 200.200.200.200 255.255.255.0
交換機基礎配置
#sysname SW1
vlan batch 2 to 3100
dhcp enable
interface Vlanif1
ip address 172.16.1.1 255.255.255.0
dhcp select interface
interface Vlanif2
ip address 172.16.2.1 255.255.255.0
dhcp select interface
interface Vlanif3
ip address 172.16.3.1 255.255.255.0
dhcp select interface
interface Vlanif100
ip address 192.168.100.2 255.255.255.0
interface GigabitEthernet 0/0/1
port link-type access
interface GigabitEthernet 0/0/2
port link-type access
port default vlan 2
interface GigabitEthernet 0/0/3
port link-type access
port default vlan 3
Interface GigabitEthernet 0/0/4
port link-type access
port default vlan 100
電腦採用DHCP方式得到地址
可以用ipconfig驗證是否三個電腦都得到地址。
•探討靜態路由匯總環路
在交換機上配置默認路由去互聯網
[SW1]ip route-static 0.0.0.0 0.0.0.0 192.168.100.1
在路由器上配置去模擬公網的默認路由
[R1]ip route-static 0.0.0.0 0.0.0.0 LoopBack 100
在路由器上配置反回VLAN的路由(這里為了減少路由表大小,採用匯總方式)
[R1]ip route-static 172.16.0.0 22 192.168.100.2
或者配置
[R1]ip route-static 172.16.0.0 16 192.168.100.2
此時在PC上測試公網互通發現一切正常
PC>ping 100.100.100.100
PC>tracert 200.200.200.200
PC>tracert 172.16.0.10
三層交換機路由表
[SW1]dis ip routing-table
路由器路由表
[R1]dis ip routing-table
電腦發包到172.16.0.10的時候,以路由最長匹配原則,在三層交換機和路由器上分別命中紅線標注的路由,下一跳互為對方,故產生環路
Ⅲ H3C-路由器、交換機配置(根據拓撲圖給例詳細命令步驟)
交換機支持的命令:
交換機基本狀態: switch: ;ROM狀態,
路由器是rommon>hostname> ;用戶模式hostname# ;特權模式hostname(config)# ;全局配置模式hostname(config-if)# ;介面狀態
交換機口令設置: switch>enable ;進入特權模式
switch#config terminal ;進入全局配置模式
switch(config)#hostname ;設置交換機的主機名
switch(config)#enable secret xxx ;設置特權加密口令
switch(config)#enable password xxa ;設置特權非密口令
switch(config)#line console 0 ;進入控制台口
switch(config-line)#line vty 0 4 ;進入虛擬終端
switch(config-line)#login ;允許登錄
switch(config-line)#password xx ;設置登錄口令
xxswitch#exit ;返回命令
交換機VLAN設置:
switch#vlan database ;進入VLAN設置
switch(vlan)#vlan 2 ;建VLAN 2
switch(vlan)#no vlan 2 ;刪vlan 2
switch(config)#int f0/1 ;進入埠1
switch(config-if)#switchport access vlan 2 ;當前埠加入
vlan 2switch(config-if)#switchport mode trunk ;設置為干線
switch(config-if)#switchport trunk allowed vlan 1,2 ;設置允許的vlan
switch(config-if)#switchport trunk encap dot1q ;設置vlan 中繼
switch(config)#vtp domain ;設置發vtp域名
switch(config)#vtp password ;設置發vtp密碼
switch(config)#vtp mode server ;設置發vtp模式
switch(config)#vtp mode client ;設置發vtp模式
交換機設置IP地址:
switch(config)#interface vlan 1 ;進入vlan 1
switch(config-if)#ip address ;設置IP地址
switch(config)#ip default-gateway ;設置默認網關
switch#dir flash: ;查看快閃記憶體
交換機顯示命令:
switch#write ;保存配置信息
switch#show vtp ;查看vtp配置信息
switch#show run ;查看當前配置信息
switch#show vlan ;查看vlan配置信息
switch#show interface ;查看埠信息
switch#show int f0/0 ;查看指定埠信息
2. 路由器支持的命令:
路由器顯示命令:
router#show run ;顯示配置信息
router#show interface ;顯示介面信息
router#show ip route ;顯示路由信息
router#show cdp nei ;顯示鄰居信息
router#reload ;重新起動
路由器口令設置:
router>enable ;進入特權模式
router#config terminal ;進入全局配置模式
router(config)#hostname ;設置交換機的主機名
router(config)#enable secret xxx ;設置特權加密口令
router(config)#enable password xxb ;設置特權非密口令
router(config)#line console 0 ;進入控制台口
router(config-line)#line vty 0 4 ;進入虛擬終端
router(config-line)#login ;要求口令驗證
router(config-line)#password xx ;設置登錄口令xx
router(config)#(Ctrl+z) ; 返回特權模式
router#exit ;返回命令
路由器配置:
router(config)#int s0/0 ;進入Serail介面
router(config-if)#no shutdown ;激活當前介面
router(config-if)#clock rate 64000 ;設置同步時鍾
router(config-if)#ip address ;設置IP地址
router(config-if)#ip address second ;設置第二個IP
router(config-if)#int f0/0.1 ;進入子介面
router(config-subif.1)#ip address ;設置子介面IP
router(config-subif.1)#encapsulation dot1q ;綁定vlan中繼協議
router(config)#config-register 0x2142 ;跳過配置文件
router(config)#config-register 0x2102 ;正常使用配置文件
router#reload ;重新引導
路由器文件操作:
router# running-config startup-config ;保存配置
router# running-config tftp ;保存配置到tftp
router# startup-config tftp ;開機配置存到tftp
router# tftp flash: ;下傳文件到flash
router# tftp startup-config;下載配置文件ROM狀態:
Ctrl+Break ;進入ROM監控狀態
rommon>confreg 0x2142 ;跳過配置文件
rommon>confreg 0x2102 ;恢復配置文件
rommon>reset ;重新引導
rommon> xmodem: flash: ;從console傳輸文件
rommon>IP_ADDRESS=10.65.1.2 ;設置路由器IP
rommon>IP_SUBNET_MASK=255.255.0.0 ;設置路由器掩碼
rommon>TFTP_SERVER=10.65.1.1 ;指定TFTP伺服器IP
rommon>TFTP_FILE=c2600.bin ;指定下載的文件
rommon>tftpdnld ;從tftp下載
rommon>dir flash: ;查看快閃記憶體內容
rommon>boot ;引導IOS
靜態路由:
ip route ;命令格式router(config)#ip route 2.0.0.0 255.0.0.0 1.1.1.2 ;
靜態路由舉例router(config)#ip route 0.0.0.0 0.0.0.0 1.1.1.2 ;默認路由舉例
動態路由:
router(config)#ip routing ;啟動路由轉發
router(config)#router rip ;啟動RIP路由協議。
router(config-router)#network ;設置發布路由
router(config-router)#negihbor ;點對點幀中繼用。