导航:首页 > 程序命令 > dell交换机命令

dell交换机命令

发布时间:2023-01-01 07:48:05

Ⅰ 戴尔交换机是用命令可配置的交换机吗

当然是!和思科的差不多。

DELL交换机的配置命令

1. 交换机支持的命令:
交换机基本状态:
switch: ;ROM状态,路由器是rommon>
hostname> ;用户模式
hostname# ;特权模式
hostname(config)# ;全局配置模式
hostname(config-if)# ;接口状态
交换机口令设置:
switch>enable ;进入特权模式
switch#config terminal ;进入全局配置模式
switch(config)#hostname;设置交换机的主机名
switch(config)#enable secret xxx ;设置特权加密口令
switch(config)#enable password xxa ;设置特权非密口令
switch(config)#line console 0 ;进入控制台口
switch(config-line)#line vty 0 4 ;进入虚拟终端
switch(config-line)#login ;允许登录
switch(config-line)#password xx ;设置登录口令xx
switch#exit ;返回命令
交换机VLAN设置:
switch#vlan database ;进入VLAN设置
switch(vlan)#vlan 2 ;建VLAN 2
switch(vlan)#no vlan 2 ;删vlan 2
switch(config)#int f0/1 ;进入端口1
switch(config-if)#switchport access vlan 2 ;当前端口加入vlan 2
switch(config-if)#switchport mode trunk ;设置为干线
switch(config-if)#switchport trunk allowed vlan 1,2 ;设置允许的vlan
switch(config-if)#switchport trunk encap dot1q ;设置vlan 中继
switch(config)#vtp domain;设置发vtp域名
switch(config)#vtp password;设置发vtp密码
switch(config)#vtp mode server ;设置发vtp模式
switch(config)#vtp mode client ;设置发vtp模式
交换机设置IP地址:
switch(config)#interface vlan 1 ;进入vlan 1
switch(config-if)#ip address;设置IP地址
switch(config)#ip default-gateway;设置默认网关
switch#dir flash: ;查看闪存
交换机显示命令:
switch#write ;保存配置信息
switch#show vtp ;查看vtp配置信息
switch#show run ;查看当前配置信息
switch#show vlan ;查看vlan配置信息
switch#show interface ;查看端口信息
switch#show int f0/0 ;查看指定端口信息
2. 路由器支持的命令:
路由器显示命令:
router#show run ;显示配置信息
router#show interface ;显示接口信息
router#show ip route ;显示路由信息
router#show cdp nei ;显示邻居信息
router#reload ;重新起动
路由器口令设置:
router>enable ;进入特权模式
router#config terminal ;进入全局配置模式
router(config)#hostname;设置交换机的主机名
router(config)#enable secret xxx ;设置特权加密口令
router(config)#enable password xxb ;设置特权非密口令
router(config)#line console 0 ;进入控制台口
router(config-line)#line vty 0 4 ;进入虚拟终端
router(config-line)#login ;要求口令验证
router(config-line)#password xx ;设置登录口令xx
router(config)#(Ctrl+z) ;返回特权模式
router#exit ;返回命令
路由器配置:
router(config)#int s0/0 ;进入Serail接口
router(config-if)#no shutdown ;激活当前接口
router(config-if)#clock rate 64000 ;设置同步时钟
router(config-if)#ip address;设置IP地址
router(config-if)#ip addresssecond ;设置第二个IP
router(config-if)#int f0/0.1 ;进入子接口
router(config-subif.1)#ip address;设置子接口IP
router(config-subif.1)#encapsulation dot1q;绑定vlan中继协议
router(config)#config-register 0x2142 ;跳过配置文件
router(config)#config-register 0x2102 ;正常使用配置文件
router#reload ;重新引导
路由器文件操作:
router# running-config startup-config ;保存配置
router# running-config tftp ;保存配置到tftp
router# startup-config tftp ;开机配置存到tftp
router# tftp flash: ;下传文件到flash
router# tftp startup-config;下载配置文件
ROM状态:
Ctrl+Break;进入ROM监控状态
rommon>confreg0x2142 ;跳过配置文件
rommon>confreg0x2102 ;恢复配置文件
rommon>reset;重新引导
rommon>xmodem: flash: ;从console传输文件
rommon>IP_ADDRESS=10.65.1.2;设置路由器IP
rommon>IP_SUBNET_MASK=255.255.0.0;设置路由器掩码
rommon>TFTP_SERVER=10.65.1.1;指定TFTP服务器IP
rommon>TFTP_FILE=c2600.bin;指定下载的文件
rommon>tftpdnld;从tftp下载
rommon>dirflash: ;查看闪存内容
rommon>boot;引导IOS

静态路由:
ip route;命令格式
router(config)#ip route 2.0.0.0 255.0.0.0 1.1.1.2 ;静态路由举例
router(config)#ip route 0.0.0.0 0.0.0.0 1.1.1.2 ;默认路由举例
动态路由:
router(config)#ip routing ;启动路由转发
router(config)#router rip ;启动RIP路由协议。
router(config-router)#network;设置发布路由
router(config-router)#negihbor;点对点帧中继用。
帧中继命令:
router(config)#frame-relay switching ;使能帧中继交换
router(config-s0)#encapsulation frame-relay ;使能帧中继
router(config-s0)#fram-relay lmi-type cisco ;设置管理类型
router(config-s0)#frame-relay intf-type DCE ;设置为DCE
router(config-s0)#frame-relay dlci 16 ;
router(config-s0)#frame-relay local-dlci 20 ;设置虚电路号
router(config-s0)#frame-relay interface-dlci 16 ;
router(config)#log-adjacency-changes ;记录邻接变化
router(config)#int s0/0.1 point-to-point ;设置子接口点对点
router#show frame pvc ;显示永久虚电路
router#show frame map ;显示映射
基本访问控制列表:
router(config)#access-listpermit|deny
router(config)#interface;default:deny any
router(config-if)#ip access-groupin|out ;default:out
例1:
router(config)#access-list4 permit 10.8.1.1
router(config)#access-list4 deny 10.8.1.0 0.0.0.255
router(config)#access-list4 permit 10.8.0.0 0.0.255.255
router(config)#access-list4 deny 10.0.0.0 0.255.255.255
router(config)#access-list4 permit any
router(config)#intf0/0
router(config-if)#ipaccess-group 4 in

扩展访问控制列表:
access-listpermit|denyicmp
wild>[type]
access-listpermit|denytcp
wild>[port]
例3:
router(config)#access-list 101 deny icmp any 10.64.0.2 0.0.0.0 echo
router(config)#access-list 101 permit ip any any
router(config)#int s0/0
router(config-if)#ip access-group 101 in
例3:
router(config)#access-list 102 deny tcp any 10.65.0.2 0.0.0.0 eq 80
router(config)#access-list 102 permit ip any any
router(config)#interface s0/1
router(config-if)#ip access-group 102 out
删除访问控制例表:
router(config)#noaccess-list 102
router(config-if)#noip access-group 101 in
路由器的nat配置
Router(config-if)#ip nat inside ;当前接口指定为内部接口
Router(config-if)#ip nat outside ;当前接口指定为外部接口
Router(config)#ip nat inside source static [p] <私有IP><公网IP> [port]
Router(config)#ip nat inside source static 10.65.1.2 60.1.1.1
Router(config)#ip nat inside source static tcp 10.65.1.3 80 60.1.1.1 80
Router(config)#ip nat pool p1 60.1.1.1 60.1.1.20 255.255.255.0
Router(config)#ip nat inside source list 1 pool p1
Router(config)#ip nat inside destination list 2 pool p2
Router(config)#ip nat inside source list 2 interface s0/0 overload
Router(config)#ip nat pool p2 10.65.1.2 10.65.1.4 255.255.255.0 type
rotary
Router#show ip nat translation
rotary 参数是轮流的意思,地址池中的IP轮流与NAT分配的地址匹配。
overload参数用于PAT将内部IP映射到一个公网IP不同的端口上。
外部网关协议配置:
routerA(config)#router bgp 100
routerA(config-router)#network 19.0.0.0
routerA(config-router)#neighbor 8.1.1.2 remote-as 200
配置PPP验证:
RouterA(config)#usernamepassword
RouterA(config)#int s0
RouterA(config-if)#ppp authentication {chap|pap}
3.PIX防火墙命令
Pix525(config)#nameif ethernet0 outside security0 ;命名接口和级别
Pix525(config)#interface ethernet0 auto ;设置接口方式
Pix525(config)#interface ethernet1 100full ;设置接口方式
Pix525(config)#interface ethernet1 100full shutdown
Pix525(config)#ip address inside 192.168.0.1 255.255.255.0
Pix525(config)#ip address outside 133.0.0.1 255.255.255.252
Pix525(config)#global (if_name) natid ip-ip ;定义公网IP区间
Pix525(config)#global (outside) 1 7.0.0.1-7.0.0.15 ;例句
Pix525(config)#global (outside) 1 133.0.0.1 ;例句
Pix525(config)#no global (outside) 1 133.0.0.1 ;去掉设置
Pix525(config)#nat (if_name) nat_id local_ip [netmark]
Pix525(config)#nat (inside) 1 0 0
内网所有主机(0代表0.0.0.0)可以访问global 1指定的外网。
Pix525(config)#nat (inside) 1 172.16.5.0 255.255.0.0
内网172.16.5.0/16网段的主机可以访问global 1指定的外网。
Pix525(config)#route if_name 0 0 gateway_ip [metric] ;命令格式
Pix525(config)#route outside 0 0 133.0.0.1 1 ;例句
Pix525(config)#route inside 10.1.0.0 255.255.0.0 10.8.0.1 1 ;例句
Pix525(config)#static (inside, outside) 133.0.0.1 192.168.0.8
表示内部ip地址192.168.0.8,访问外部时被翻译成133.0.0.1全局地址。
Pix525(config)#static (dmz, outside) 133.0.0.1 172.16.0.8
中间区域ip地址172.16.0.8,访问外部时被翻译成133.0.0.1全局地址

Ⅱ Dell交换机常见配置

默认的用户名和密码都是 admin,如果希望修改或添加新的用户,请参考下列命令:

OS10# configure terminal

OS10(config)# username admin password password_2018 role sysadmin

OS10(config)# end

OS10# write memory

1配置本地时间

OS10# configure terminal

OS10(config)# clock timezone UTC 8 0

OS10(config)# end

OS10# clock set 22:49:00 2018-03-29

OS10# show clock

2018-03-29T22:49:10.06+08:00

OS10#write

2 NTP 校时

OS10(config)# clock timezone UTC 8 0

OS10(config)# do show clock

2018-03-30T06:26:15.24+08:00

OS10(config)# ntp server 192.168.220.159

OS10(config)# do write

1 Access 模式

例:创建 VLAN10 并将 e1/1/1 接口以 access 模式划入 vlan10.

OS10# configure terminal

OS10(config)# interface vlan 10

OS10(conf-if-vl-10)# exit

OS10(config)# interface e1/1/1

OS10(conf-if-eth1/1/1)# switchport mode access

OS10(conf-if-eth1/1/1)# switchport access vlan 10

OS10(conf-if-eth1/1/1)# no shutdown

OS10(conf-if-eth1/1/1)# do write

2Trunk 模式

例:创建 VLAN10 和 20,并将 e1/1/2 接口配置为 trunk 模式且放行 vlan10 和 20.

OS10# configure terminal

OS10(config)# interface vlan 20

OS10(conf-if-vl-20)# exit

OS10(config)# interface e1/1/2

OS10(conf-if-eth1/1/2)# switchport mode trunk

OS10(conf-if-eth1/1/2)# switchport trunk allowed vlan 10,20

OS10(conf-if-eth1/1/2)# show configuration

!

interface ethernet1/1/2

no shutdown

switchport mode trunk

switchport access vlan 1 (如果你希望 native vlan 为 2,此处请 switch access vlan 2 )

switchport trunk allowed vlan 10,20

OS10(conf-if-eth1/1/2)# do write memory

3修改默认 VLAN

OS10 默认 VLAN 是 1 且默认所有 trunk 口都 untagged vlan1,如果需要修改其他 VLAN 为

默认 VLAN,参考如下:

OS10# configure terminal

OS10(config)# interface vlan 4093

OS10(conf-if-vl-4093)# exit

OS10(config)# default vlan-id 4093

OS10(config)# do show vlan

Codes: * - Default VLAN, M - Management VLAN, R - Remote Port Mirroring VLANs

Q: A - Access (Untagged), T - Tagged

NUM Status Description Q Ports

1 Inactive

* 4093 Active A Eth1/1/1-1/1/32

OS10(config)#do write

1静态链路聚合

本例:对 e1/1/49 和 50 接口静态聚合为 PO1,并且配置为 trunk 模式和放行 vlan10,20

OS10# configure terminal

OS10(config)# interface port-channel 1

OS10(conf-if-po-1)# switchport mode trunk

OS10(conf-if-po-1)# switchport trunk allowed vlan 10,20

OS10(conf-if-po-1)# no shutdown

OS10(conf-if-po-1)# exit

OS10(config)# interface range e1/1/49-1/1/50

OS10(conf-range-eth1/1/49-1/1/50)# channel-group 1

OS10(conf-range-eth1/1/49-1/1/50)# no shutdown

OS10(conf-range-eth1/1/49-1/1/50)# end

OS10#write

查看:

OS10# show interface port-channel 1 summary

2动态 LACP 聚合

OS10# configure terminal

OS10(config)# interface port-channel 1

OS10(conf-if-po-1)# switchport mode trunk

OS10(conf-if-po-1)# switchport trunk allowed vlan 10,20

OS10(conf-if-po-1)# no shutdown

OS10(conf-if-po-1)# exit

OS10(config)# interface range e1/1/49-1/1/50

OS10(conf-range-eth1/1/49-1/1/50)# channel-group 1 mode active

OS10(conf-range-eth1/1/49-1/1/50)# no shutdown

OS10(conf-range-eth1/1/49-1/1/50)# end

OOS100#write

查看:

OOS100# show interface port-channel 1 summary

本例中,将 e1/1/1 口的进和出两个方向的流量镜像到 e1/1/2 口进行抓包分析。

OS10(config)# interface e1/1/2

OS10(conf-if-eth1/1/2)# no switchport

OS10(conf-if-eth1/1/2)#exit

OS10(config)# monitor session 1

OS10(conf-mon-local-1)# source interface ethernet 1/1/1 both

OS10(conf-mon-local-1)# destination interface e1/1/2

OS10(conf-mon-local-1)# no shut

目前,OS10 默认使用 TCP 协议将日志传递给外部的 Syslog Server。所以请确保 syslog server

侦听 TCP 514 端口。

OS10 默认的日志级别为 notice。

OS10#config t

OS10(config)# logging log-file severity log-debug

OS10(config)# logging server 192.168.220.159 severity log-debug udp

OS10(config)# logging enable

OS10(config)# do write

另,如果需要启用审计日志功能(记录交换机用户的命令操作记录),如下

OS10(config)# logging audit enable

OS10(config)# show logging audit

本例,配置 snmp community 为 dell 且为只读

OS10# configure terminal

OS10(config)# snmp-server community dell ro

如果需要配置 snmp server 和启用 trap,则参考如下 :

OS10(config)# snmp-server host 1.1.1.1 version 2c dell

OS10(config)# snmp-server enable traps

OS10(config)# do write

1 带外管理 IP 配置

OS10# show running-configuration interface mgmt 1/1/1

!

interface mgmt1/1/1

no shutdown

ip address dhcp

ipv6 address autoconfig

OS10#

OS10# configure terminal

OS10(config)# interface mgmt 1/1/1

OS10(conf-if-ma-1/1/1)# no ip address dhcp

OS10(conf-if-ma-1/1/1)# no ipv6 address autoconfig

OS10(conf-if-ma-1/1/1)# exit

OS10(config)# ip vrf management

OS10(conf-vrf)# interface management

OS10(conf-vrf)# exit

OS10(config)# interface mgmt 1/1/1

OS10(conf-if-ma-1/1/1)# ip address 10.0.0.1/24

OS10(conf-if-ma-1/1/1)# no shutdown

OS10(conf-if-ma-1/1/1)# show configuration

!

interface mgmt1/1/1

no shutdown

no ip address dhcp

ip address 10.0.0.1/24

OS10(conf-if-ma-1/1/1)# exit

OS10#OS10(config)# management route 0.0.0.0/0 172.16.1.254 (带外网络默认路由)

OS10(config)#do write

2 带内管理 IP 配置

此处所谓带内是相对于带外而言,本例中指的是 VLAN 接口(SVI)IP 地址的配置:

OS10(config)# interface vlan 1

OS10(conf-if-vl-1)# ip address 192.168.1.1/24

OS10(conf-if-vl-1)# no shutdown

OS10(conf-if-vl-1)# exit

OS10(config)# ip route 0.0.0.0/0 192.168.1.254 (带内网络的默认网关)

OS10(config)# do write

备注:上述是以 VLAN 1 作为例子,请根据您的 VLAN 规划自行修改。

注意:如果同时配置了带内和带外默认路由,带外管理口 MGMT 1/1/1 必须划入

Management VRF 中,否则仅带内默认路由生效。

Ⅲ DellS4128F-ON交换机配置SNMP步骤

a) SSH软件登录到交换机IP
b) enable
c) config
d) snmp-server community public ro #ro:只读 rw:读写
e) snmp-server enable traps
f) snmp-server host 监控服务器IP version 2c public
g) end
h) wr
i) show snmp community

注:可以用?来列出所有可能的命令列表

Ⅳ dell 刀片交换机如何升级固件

通过TFTP升级 在电脑上配置好TFTP server,设置固定IP地址,将要升级固件放在TFTP server。
进入交换机后,执行命令: get x.x.x.x(TFTP服务器地址)固件文件名称 等文件下载好后,重启交换机,在启动过程中按ctrl键+B键打断系统加载,进入交换机升级模式 选择其中升级选项或者通过命令加载新的固件。加载好后重启交换机就可以了。

Ⅳ dell 5524交换机初始化(恢复出厂设置)命令

您好:
以下方法供您参考:
戴尔电脑恢复出厂设置的方法如下:(1)、开机进入系统前,按F8,进入Windows 7的高级启动选项,选择“修复计算机”。(2)、选择键盘输入方法。(3)、如果有管理员密码,需要输入;如果没有设置密码,直接“确定”即可。(4)、进入系统恢复选项后,选择“Dell DataSafe 还原和紧急备份”。(5)、选择“选择其他系统备份和更多选项”,点击“下一步”。(6)、选择“还原我的计算机”,点击“下一步”。(7)、选择正确的出厂映像后,点击“下一步”就可以开始恢复系统到出厂状态。注意,在恢复过程中,笔记本需要连接适配器。完成后,重启电脑即可。

Ⅵ dell 5524交换机初始化(恢复出厂设置)命令

则在重启时,需要连按
ctrl+f
在出现菜单后,选择R初始化,最后选择Q退出
初始用户和密码是admin
admin

阅读全文

与dell交换机命令相关的资料

热点内容
加密手机号码是怎么回事 浏览:921
女程序员真实图片 浏览:696
pic单片机烧写 浏览:814
linuxping结果 浏览:196
单片机采集负电压 浏览:407
服务器收件什么意思 浏览:893
单片机发数组 浏览:884
魔方虚拟主机销售系统源码 浏览:709
rsa验签php源码 浏览:514
github怎么直接打开源码 浏览:529
和家亲app怎么下载不了了 浏览:728
蓝屏程序员 浏览:78
androidinflatexml 浏览:489
魔兽争霸2下载好了怎么解压 浏览:920
怎么做少女心解压本 浏览:203
php刷新cookie 浏览:737
推荐服务器怎么关闭 浏览:615
dos命令隐藏窗口 浏览:591
三国志13用什么解压 浏览:979
单片机水雾化的方法 浏览:248