1. 三层交换机的网络拓扑图和配置命令怎么做啊
以思科三层交换机为例:
1、网络拓扑图:
2、配置命令:
1)路由器的配置:
interface FastEthernet0/0
ip address 10.66.88.222 255.255.255.0
ip nat outside
plex auto
speed auto
interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.0
ip nat inside
plex auto
speed auto
interface Vlan1
no ip address
shutdown
ip nat
inside source list 1 interface FastEthernet0/0 overload
ip classless
ip route 192.168.2.0 255.255.255.0 192.168.1.222
ip route 192.168.3.0
255.255.255.0 192.168.1.222
access-list 1 permit 192.168.0.0 0.0.255.255
2)三层交换机的配置:
hostname L3-SW
ip dhcp pool vlan2pool
network 192.168.3.0
255.255.255.0
default-router 192.168.3.1
dns-server 202.101.172.35
ip dhcp pool vlan1pool
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1
dns-server 202.101.172.35
interface
FastEthernet0/1
no switchport
ip address 192.168.1.222 255.255.255.0
plex auto
speed auto
interface FastEthernet0/2
switchport mode
trunk
interface FastEthernet0/5
switchport mode trunk
interface
Vlan1
ip address 192.168.2.1 255.255.255.0
interface Vlan2
ip address 192.168.3.1 255.255.255.0
ip classless
ip route 0.0.0.0 0.0.0.0
192.168.1.1
2. 三层交换机如何配置DHCP服务
配置CISCO三层交换机DHCP服务的步骤:
1、首先将三层交换机开机,电脑telnet 远程连接,并进入全局模式下,
2、在全局模式下开启DHCP服务,输入“service dhcp”,然后按回车,
3、指定不通过DHCP 地址池中分配的地址,也就是排除的地址。这里排除192.168.1.1到192.168.1.10的地址,输入“ip dhcp excluded-address 192.168.1.1 192.168.1.10"
4、配置一个名为“cs”的地址池,输入”ip dhcp pool cs",
5、指定要通过DHCP分配的网段和掩码,输入”network 192.168.1.0 255.255.255.0",
6、为客户机配置DNS服务器,输入“dns-server 218.2.135.1",
7、设置地址租用期为”3“,输入”lease 3",租期可以根据实际情况做调整,
8、为客户机配置网关为“192.168.1.1”,输入“default-router 192.168.1.1”,
9、这样就设置完成了,只要是属于192.168.1.0/24网段的客户机就可以自动获取IP地址了。这里注意了,如果存在多个VLAN,每个VLAN都需要设置DHCP服务。
3. 交换机与路由器的常用配置命令是什么
1.交换机支持的命令:
交换机基本状态:switch:;ROM状态,
路由器是rommon>hostname>;用户模式hostname#;特权模式hostname(config)#;全局配置模式hostname(config-if)#;接口状态
交换机口令设置:switch>enable;进入特权模式
switch#configterminal;进入全局配置模式
switch(config)#hostname;设置交换机的主机名
switch(config)#enablesecretxxx;设置特权加密口令
switch(config)#enablepasswordxxa;设置特权非密口令
switch(config)#lineconsole0;进入控制台口
switch(config-line)#linevty04;进入虚拟终端
switch(config-line)#login;允许登录
switch(config-line)#passwordxx;设置登录口令
xxswitch#exit;返回命令
交换机VLAN设置:
switch#vlandatabase;进入VLAN设置
switch(vlan)#vlan2;建VLAN2
switch(vlan)#novlan2;删vlan2
switch(config)#intf0/1;进入端口1
switch(config-if)#switchportaccessvlan2;当前端口加入
vlan2switch(config-if)#switchportmodetrunk;设置为干线
switch(config-if)#switchporttrunkallowedvlan1,2;设置允许的vlan
switch(config-if)#switchporttrunkencapdot1q;设置vlan中继
switch(config)#vtpdomain;设置发vtp域名
switch(config)#vtppassword;设置发vtp密码
switch(config)#vtpmodeserver;设置发vtp模式
switch(config)#vtpmodeclient;设置发vtp模式
交换机设置IP地址:
switch(config)#interfacevlan1;进入vlan1
switch(config-if)#ipaddress;设置IP地址
switch(config)#ipdefault-gateway;设置默认网关
switch#dirflash:;查看闪存
交换机显示命令:
switch#write;保存配置信息
switch#showvtp;查看vtp配置信息
switch#showrun;查看当前配置信息
switch#showvlan;查看vlan配置信息
switch#showinterface;查看端口信息
switch#showintf0/0;查看指定端口信息
2.路由器支持的命令:
路由器显示命令:
router#showrun;显示配置信息
router#showinterface;显示接口信息
router#showiproute;显示路由信息
router#showcdpnei;显示邻居信息
router#reload;重新起动
路由器口令设置:
router>enable;进入特权模式
router#configterminal;进入全局配置模式
router(config)#hostname;设置交换机的主机名
router(config)#enablesecretxxx;设置特权加密口令
router(config)#enablepasswordxxb;设置特权非密口令
router(config)#lineconsole0;进入控制台口
router(config-line)#linevty04;进入虚拟终端
router(config-line)#login;要求口令验证
router(config-line)#passwordxx;设置登录口令xx
router(config)#(Ctrl+z);返回特权模式
router#exit;返回命令
路由器配置:
router(config)#ints0/0;进入Serail接口
router(config-if)#noshutdown;激活当前接口
router(config-if)#clockrate64000;设置同步时钟
router(config-if)#ipaddress;设置IP地址
router(config-if)#ipaddresssecond;设置第二个IP
router(config-if)#intf0/0.1;进入子接口
router(config-subif.1)#ipaddress;设置子接口IP
router(config-subif.1)#encapsulationdot1q;绑定vlan中继协议
router(config)#config-register0x2142;跳过配置文件
router(config)#config-register0x2102;正常使用配置文件
router#reload;重新引导
路由器文件操作:
router#running-configstartup-config;保存配置
router#running-configtftp;保存配置到tftp
router#startup-configtftp;开机配置存到tftp
router#tftpflash:;下传文件到flash
router#tftpstartup-config;下载配置文件ROM状态:
Ctrl+Break;进入ROM监控状态
rommon>confreg0x2142;跳过配置文件
rommon>confreg0x2102;恢复配置文件
rommon>reset;重新引导
rommon>xmodem:flash:;从console传输文件
rommon>IP_ADDRESS=10.65.1.2;设置路由器IP
rommon>IP_SUBNET_MASK=255.255.0.0;设置路由器掩码
rommon>TFTP_SERVER=10.65.1.1;指定TFTP服务器IP
rommon>TFTP_FILE=c2600.bin;指定下载的文件
rommon>tftpdnld;从tftp下载
rommon>dirflash:;查看闪存内容
rommon>boot;引导IOS
静态路由:
iproute;命令格式router(config)#iproute2.0.0.0255.0.0.01.1.1.2;
静态路由举例router(config)#iproute0.0.0.00.0.0.01.1.1.2;默认路由举例
动态路由:
router(config)#iprouting;启动路由转发
router(config)#routerrip;启动RIP路由协议。
router(config-router)#network;设置发布路由
router(config-router)#negihbor;点对点帧中继用。
最好是去官方网站参考手册。