A. 交换机基本配置命令
一、单交换机VLAN划分
命令 命令解释
system 进入系统视图
system-view 进入系统视图
quit 退到系统视图
undo vlan 20 删除vlan 20
sysname 交换机命名
disp vlan 显示vlan
vlan 20 创建vlan(也可进入vlan 20)
port e1/0/1 to e1/0/5 把端口1-5放入VLAN 20 中
disp vlan 20 显示vlan里的端口20
int e1/0/24 进入端口24
port access vlan 20 把当前端口放入vlan 20
undo port e1/0/10 表示删除当前VLAN端口10
disp curr 显示当前配置
二、配置交换机支持TELNET
system 进入系统视图
sysname 交换机命名
int vlan 1 进入VLAN 1
ip address 192.168.3.100 255.255.255.0 配置IP地址
user-int vty 0 4 进入虚拟终端
authentication-mode password (aut password) 设置口令模式
set authentication password simple 222 (set aut pass sim 222) 设置口令
user privilege level 3(use priv lev 3) 配置用户级别
disp current-configuration (disp cur) 查看当前配置
disp ip int 查看交换机VLAN IP配置
删除配置必须退到用户模式
reset saved-configuration(reset saved) 删除配置
reboot 重启交换机
三、跨交换机VLAN的通讯
在sw1上:
vlan 10 建立VLAN 10
int e1/0/5 进入端口5
port access vlan 10 把端口5加入vlan 10
vlan 20 建立VLAN 20
int e1/0/15 进入端口15
port access vlan 20 把端口15加入VLAN 20
int e1/0/24 进入端口24
port link-type trunk 把24端口设为TRUNK端口
port trunk permit vlan all 同上
在SW2上:
vlan 10 建立VLAN 10
int e1/0/20 进入端口20
port access vlan 10 把端口20放入VLAN 10
int e1/0/24 进入端口24
port link-type trunk 把24端口设为TRUNK端口
port trunk permit vlan all (port trunk permit vlan 10 只能为vlan
10使用)24端口为所有VLAN使用
disp int e1/0/24 查看端口24是否为TRUNK
undo port trunk permit vlan all 删除该句
四、路由的配置命令
system 进入系统模式
sysname 命名
int e1/0 进入端口
ip address 192.168.3.100 255.255.255.0 设置IP
undo shutdown 打开端口
disp ip int e1/0 查看IP接口情况
disp ip int brief 查看IP接口情况
user-int vty 0 4 进入口令模式
authentication-mode password(auth pass) 进入口令模式
set authentication password simple 222 37 设置口令
user privilege level 3 进入3级特权
save 保存配置
reset saved-configuration 删除配置(用户模式下运行)
undo shutdown 配置远程登陆密码
int e1/4
ip route 192.168.3.0(目标网段) 255.255.255.0 192.168.12.1(下一跳:下一路由器的接口) 静态路由
ip route 0.0.0.0 0.0.0.0 192.168.12.1 默认路由
disp ip rout 显示路由列表
华3C AR-18
E1/0(lan1-lan4)
E2/0(wan0)
E3/0(WAN1)
路由器连接使用直通线。wan0接wan0或wan1接wan1
计算机的网关应设为路由器的接口地址。
五、三层交换机配置VLAN-VLAN通讯
sw1(三层交换机):
system 进入视图
sysname 命名
vlan 10 建立VLAN 10
vlan 20 建立VLAN 20
int e1/0/20 进入端口20
port access vlan 10 把端口20放入VLAN 10
int e1/0/24 进入24端口
port link-type trunk 把24端口设为TRUNK端口
port trunk permit vlan all (port trunk permit vlan 10 只能为vlan
10使用)24端口为所有VLAN使用
sw2:
vlan 10
int e1/0/5
port access vlan 10
int e1/0/24
port link-type trunk 把24端口设为TRUNK端口
port trunk permit vlan all (port trunk permit vlan 10 只能为vlan
10使用)24端口为所有VLAN使用
sw1(三层交换机):
int vlan 10 创建虚拟接口VLAN 10
ip address 192.168.10.254 255.255.255.0 设置虚拟接口VLAN 10的地址
int vlan 20 创建虚拟接口VLAN 20
ip address 192.168.20.254 255.255.255.0 设置虚拟接口IP VLAN 20的地址
注意:vlan 10里的计算机的网关设为 192.168.10.254
vlan 20里的计算机的网关设为 192.168.20.254
六、动态路由RIP
R1:
int e1/0 进入e1/0端口
ip address 192.168.3.1 255.255.255.0 设置IP
int e2/0 进入e2/0端口
ip adress 192.168.5.1 255.255.255.0 设置IP
rip 设置动态路由
network 192.168.5.0 定义IP
network 192.168.3.0 定义IP
disp ip rout 查看路由接口
R2:
int e1/0 进入e1/0端口
ip address 192.168.4.1 255.255.255.0 设置IP
int e2/0 进入e2/0端口
ip adress 192.168.5.2 255.255.255.0 设置IP
rip 设置动态路由
network 192.168.5.0 定义IP
network 192.168.4.0 定义IP
disp ip rout 查看路由接口
(注意:两台PC机的网关设置PC1 IP:192.168.3.1 PC2 IP:192.168.4.1)
七、IP访问列表
int e1/0
ip address 192.168.3.1 255.255.255.0
int e2/0
ip address 192.168.1.1 255.255.255.0
int e3/0
ip address 192.168.2.1 255.255.255.0
acl number 2001 (2001-2999属于基本的访问列表)
rule 1 deny source 192.168.1.0 0.0.0.255 (拒绝地址192.168.1.0网段的数据通过)
rule 2 permit source 192.168.3.0 0.0.0.255(允许地址192.168.3.0网段的数据通过)
以下是把访问控制列表在接口下应用:
firewall enable
firewall default permit
int e3/0
firewall packet-filter 2001 outbound
disp acl 2001 显示信息
undo acl number 2001 删除2001控制列表
扩展访问控制列表
acl number 3001
rule deny tcp source 192.168.3.0 0.0.0.255 destination 192.168.2.0 0.0.0.255
destination-port eq ftp
必须在r-acl-adv-3001下才能执行
rule permit ip source an destination any (rule permit ip)
int e3/0
firewall enable 开启防火墙
firewall packet-filter 3001 inbound
必须在端口E3/0下才能执行
八、命令的标准访问IP列表(三层交换机):
允许A组机器访问服务器内资料,不允许访问B组机器(服务器没有限制)
sys
vlan 10
name server
vlan 20
name teacher
vlan 30
name student
int e1/0/5
port access vlan 10
int e1/0/10
port access vlan 20
int e1/0/15
port access vlan 30
int vlan 10
ip address 192.168.10.1 255.255.255.0
undo sh
int vlan 20
ip address 192.168.20.1 255.255.255.0
int vlan 30
ip address 192.168.30.1 255.255.255.0
acl number 2001
rule 1 deny source 192.168.30.0 0.0.0.255
rule 2 permit source any
disp acl 2001 查看2001列表
int e1/0/10
port access vlan 20
packet-filter outbound ip-group 2001 rule 1
出口
九、允许A机器访问B机器的FTP但不允许访问WWW,C机器没有任何限制。
vlan 10
vlan 20
vlan 30
int e1/0/5
port access vlan 10
int e1/0/10
port access vlan 20
int e1/0/15
port access vlan 30
int vlan 10
ip address 192.168.10.1 255.255.255.0
undo sh
int vlan 20
ip address 192.168.20.1 255.255.255.0
int vlan 30
ip address 192.168.30.1 255.255.255.0
acl number 3001
rule 1 deny tcp source 192.168.30.0 0.0.0.255 destination 192.168.10.0
0.0.0.255 destination-port eq www
int e1/0/15
packet-filter inbound ip-group 3001 rule 1
进口
十、NAT地址转换(单一静态一对一地址转换)
R1:
sys
sysname R1
int e1/0
ip address 192.168.3.1 255.255.255.0
int e2/0
ip address 192.1.1.1 255.255.255.0
R2:
sys
sysname R2
int e2/0
ip address 192.1.1.2 255.255.255.0
int e1/0
ip address 10.80.1.1 255.255.255.0
回到R1:
nat static 192.168.3.1 192.1.1.1
int e2/0
nat outbound static
ip route 0.0.0.0 0.0.0.0 192.1.1.2
十一、NAT内部整网段地址转换
R1:
sys
sysname R1
int e1/0
ip address 192.168.3.1 255.255.255.0
int e2/0
ip address 192.1.1.1 255.255.255.0
acl number 2008
rule 0 permit source 192.168.3.0 0.0.0.255
rule 1 deny
quit
int e2/0
nat outbound 2008
quit
ip route-static 0.0.0.0 0.0.0.0 192.1.1.2 preference 60
B. 交换机的基本命令
一、设备的工作模式
1、用户模式
Switch>
可以查看交换机的基本简单信息,且不能做任何修改配置!
2、特权模式
Switch> enableSwitch#
可以查看所有配置,且不能修改配置!
3、全局配置模式
switch# configure terminal
switch(config)#
默认不能查看配置!可以修改配置,且全局生效!
4、接口模式
Switch(config)# int f0/2
Switch(config-if)#
默认不能查看配置!可以修改配置,且对该端口生效!
5、控制台模式
Switch(config)# line console 0
Switch(config-line)#
F0/1,E0/1 , G0/1 TE0/1
F代表100M网口,E代表10M,G代表1000M,Te代表10000M
0模块号
1接口号
二、设备命令行的功能
1、?的用法
2、命令支持简写
3、命令可以补全Tab键
4、命令历史记忆功能,上下键来调用!
三、常用基本命令
1、设置设备名
Switch(config)# hostname bj-sw-1-1
bj-sw-1-1(config)#
2、设置用户密码
sw1(config)#line co 0sw1(config-line)#password 123.com #建议密码至少6位
sw1(config-line)#login #login作用使用户密码生效!sw1(config-line)#exit
3、设置特权密码
sw1(config)# enable password 456.com # 明文的特权密码
sw1(config)# enable secret 456.com # 密文的特权密码,与明文同时配置,明文失效!
4、!!查看接口列表!!
show ip int b
5、查看MAC地址表
show mac-address-table
6、给路由器接口配置IP地址
(2层交换机端口不能配置IP)
路由器初次配置时,有1个询问,我们选择no进入高级配置模式!
Router(config)# int f0/0
Router(config-if)# ip add 192.168.1.254 255.255.255.0
Router(config-if)# no shutdown
7、为路由器开启telnet服务
Router(config)# line vty 0 2 # 2也可以改为1或3等等。代表同时远程的数量
Router(config-line)# password 123.com # 设置远程telnet密码
Router(config-line)# login
Router(config-line)# exit
Router(config)# enable password 789.com
9、重启设备
Router# reload
10、!!查看所有配置!!
Router# show running-config
简写 sh run
注释:sh run是我们以后常用的命令,用于排除错误!
11、保存设备的配置
Router# running-config startup-config
或
Router# write
12、购买模块
先关机,再购买模块,再开机!
NM-2FE2W,该模块带有2个百兆端口!
13、手工开启端口
R2(config)# int f0/1
R2(config-if)# no shutdown
14、手工关闭端口
R2(config)#int f0/1
R2(config-if)# shutdown
15、不同身份telnet连接
Router(config)# line vty 0 2 # 2也可以改为1或3等等。代表同时远程的数量
Router(config-line)# login local
Router(config-line)# exit
Router(config)# username 用户名 password 密码
Router(config)# enable password 789.com
16、do的用法
特权模式的命令,在全局或接口模式下可以强行使用,需要在命令前加do空格即可!
17、如何删除一条配置?
方法:
1)首先在什么模式下配置的,就在什么模式下删!
2)在原命令前no空格即可!注意:原命令中如有自定义参数,一般删除时不需要加参数!
18、基线核查
基线核查:按照基线文档对客户的设备进行安全核查,
安全加固:按照基线文档对客户的设备进行安全配置
19、加密所有密码
R2(config)# service password-encryption
20、给交换机配置虚拟接口IP
作用:给交换机起个IP名字!方便被远程管理!
sw1(config)# int vlan 1
sw1(config-if)# ip add 192.168.1.253 255.255.255.0
sw1(config-if)# no shut
C. 交换机的基本命令
交换机的启动及基本配置
1924交换机上配置
sw1924_b#delete nvram
全部清除交换机的所有配置
sw1924_b#reload
重新启动交换机(初始提示符为> )
sw1924_b#hostname sw1924
设置交换机的主机名
sw1924_b#enable secret cisco
设置加密密码
sw1924_b#enable password level 1 cisco1
设置等级密码(1最低)
sw1924_b#enable password level 15 cisco15
设置等级密码(15最高)
sw1924_b#ip address 192.168.14.1 255.255.255.0
设置交换机的管理IP地址
sw1924_b#ip default-gateway 192.168.198.2
设置交换机的网关地址
sw1924_b#ip domain-name pctc.com.cn
设置交换机所连域的域名
sw1924_b#ip name-server 218.87.18.230
设置交换机所连域的域名服务器IP
sw1924_b#show ip
查看上述设置环境
sw1924_b#show version
查看交换机的版本等信息
sw1924_b#show running-config
查看交换机的当前运行配置等全部信息
sw1924_b#show int e0/1
查看交换机的第1个端口信息
1924交换机配置端口属性
sw1924_b#conf t
sw1924_b#interface ethernet 0/1
进入第1个端口
sw1924_b#description sw1924_b-e0/1-pc1
给端口写入注释信息
sw1924_b#plex auto/full/full-flow-control/half
设置端口的工作模式
sw1924_b#port secure
启用端口安全性
sw1924_b#port secure max-mac-count 1
设置该端口允许对应的MAC地址数(默认132个)
sw1924_b#sh mac-address-table security
查看端口安全性
sw1912_a#conf t
进入全局配置模式
sw1912_a#interface fastethernet 0/1
进入第1个端口
sw1912_a#description sw2912_a-f0/1-pc1
给端口写入注释信息
sw1912_a#plex auto/full/half
设置端口的工作模式
sw1912_a#port security
启用端口安全性
sw1912_a#port security max-mac-count 1
设置该端口允许对应的MAC地址数(默认132个)
sw1912_a#end
返回特权模式
sw1912_a#sh port security
查看端口安全性
配置和查看MAC地址表
1924交换机配置MAC地址表
sw1924_b#mac-address-table aging-time 600
设置动态地址超时时间
sw1924_b#mac-address-table permanent 0000.0cdd.5a4d e0/3
定义永久MAC地址(绑定MAC地址)
sw1924_b#mac-address-table restricted static 0000.0cdd.aaed e0/6 e0/7
定义受限MAC地址
sw1924_b#address-violation disable/ignore/suspend
定义地址安全违规
sw1924_b#show mac-address-table
查看上述配置
sw1924_b#clear mac-addr restric static
清除受限MAC地址表项
2912交换机配置MAC地址表
sw2912_a#mac-address-table aging-time 700
设置动态地址超时时间
sw2912_a#mac-address-table static 0000.0cdd.5a4d e0/3
定义永久MAC地址(绑定MAC地址)
sw2912_a#mac-address-table secure 00d0.f80d.3333 f0/3 vlan 1
定义受限MAC地址
sw2912_a#port security action shutdown/trap
定义地址安全违规
sw2912_a#show port security
查看上述配置
配置VTP、VLAN、VLAN Trunk和STP
配置VTP
sw1924_a#conf t
sw1924_a#vtp server
定义VTP的工作模式
sw1924_a#vtp domain cisco
定义VTP的域名
sw1924_a#trunk on
启用干道
sw1924_b#vtp domain cisco
加入VTP域
sw1924_b#vtp client
定义VTP的工作模式
sw1924_b#trunk on
启用干道
sw1924_a#show trunk b
sw1924_a#show trunk b allowed-vlans
查看干道信息
配置VLAN
sw1924_a#vlan 10 dept1
sw1924_a#vlan 20 dept2
sw1924_a#vlan 30 dept3
sw1924_a#vlan 40 dept4
定义所需VLAN
sw1924_a#show vlan
查看VLAN信息
sw1924_b#show vlan
sw1924_b#show vtp
查看VTP的信息
sw1924_b#int e0/1
sw1924_b#vlan-membership static 10
sw1924_b#int e0/2
sw1924_b#vlan-membership static 20
sw1924_b#int e0/3
sw1924_b#vlan-membership static 30
sw1924_b#int e0/4
sw1924_b#vlan-membership static 40
把接口划入各自VLAN
配置spanning tree
sw1924_b#spantree 1
启用生成树协议
sw1924_b#sh spantree 1
查看生成树信息
sw1924_b#no spantree 1
关闭生成树协议
sw1924_b#sh spantree 1
查看生成树信息
D. 交换机的常用配置命令
a、更改远程TELNNET密码
Switch#configure terminal
Switch(config)#line vty 0 4
Switch(config-line)#password qycx123
Switch(config-line)#login
Switch(config-line)#exit
b、更改进入全局配置模式时的密码
Switch#configure terminal
Switch(config)#enable secret qycx123
思科交换机常用命令——创建并划分VLAN
a、创建VLAN
Switch#vlan database
Switch(vlan)#vlan 99 name office (创建vlan 99 并命名为office)
b、将端口划分至vlan
Switch(config)#interface fastEthernet 0/8
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 99 (将8号快速以太口划分至vlan 99)
思科交换机常用命令——调试命令
a、显示所有配置命令:Switch#show run
b、显示所有接口状态:Switch#show ip int brief
c、显示所有VLAN的信息:Switch#show vlan brief
cisco交换机还是比较常用的,于是我研究了一下Cisco交换机命令的大总结,在这里拿出来和大家分享一下,希望对大家有用。我所针对的都是Cisco的设备而言的,华为的可以跟据手册来查,配置都是差不多的,这里华子就不多写华为的设备了,了解的也不是很多。
Cisco交换机命令之使用Telnet远程式管理
switch(config)#interface vlan 1 进入vlan 1
switch(config-if)#ip address 设置IP地址
switch(config-if)#ip default-gateway 设置默认网关
switch(config)#line vty 0 4 进入虚拟终端
switch(config-line)#login 允许登录
switch(config-line)#password xx 设置登录口令
switch#exit 返回命令
Cisco交换机命令之控制台口令
switch(config)#line console 0 进入控制台口
switch(config-line)#login 允许登录
switch(config-line)#password xx 设置登录口令
switch#exit 返回命令
Cisco交换机命令之基本接口配置
switch(config)#interface f0/1 进入f0/1接口
switch(config-if)#plex full 配置全双工模式
switch(config-if)#speed 100 配置速率
switch(config-if)#description to ***** 接口描述
switch(config)#ip domain-name ***.com 设置或名服务器
switch(config)#mac-address-table aging-time 设置mac表超时时间
switch#write 保存配置信息
switch# running-config startup-config 保存当前配置nvram
switch#erase startup-config 清除配置文件
Cisco交换机命令之交换机VLAN设置:
switch#vlan database 进入VLAN设置
switch(vlan)#vlan 2 建VLAN 2
switch(vlan)#name 名字 建VLAN 2的名称
switch(vlan)#no vlan 2 删vlan 2
注:删除vlan时原属于此vlan的端口处于非激活状态,直到重新分配为止。
switch(config)#int f0/1 进入端口1
switch(config-if)#switchport mode access 当前端口工作莫试
switch(config-if)#switchport access vlan 2 当前端口加入vlan 2
switch(config-if)#switchport mode trunk 设置为干线
switch(config-if)#switchport trunk encapsulation dot1q 设置vlan 中继协议
switch(config-if)#no switchport mode 或 ( switchport mode access) 禁用干线
switch(config-if)#switchport trunk allowed vlan add 1,2 ; 从Trunk中添加vlans
switch(config-if)#switchport trunk allowed vlan remove 1,2 ;从Trunk中删除vlans
switch(config-if)#switchport trunk pruning vlan remove 1,2 ;从Trunk中关闭局部修剪
Cisco交换机命令之以太网通道配置
switch(config)#interface range fasternet0/1 - 2 将fasternet0/1和0/2 口捆绑
switch(config-if)#channel-group 1 mode on 配置以太通道模式
switch(config-if)#port-channel load-balance {dst-mac | src-mac}在链路间实现负载均衡
switch#show etherchannel 1 summary 查看通道信息
switch#show etherchannel load-balance 查看通道信息
Cisco交换机命令之vtp配置
switch(config)#vtp domain 设置vtp域名
switch(config)#vtp password 设置vtp密码
switch(config)#vtp mode server 设置vtp服务器模式
switch(config)#vtp mode client 设置vtp客户机模式
switch(config)#vtp mode transparent 设置vtp 透明模式
switch(config)#vtp version 设置vtp版本
switch(config)#vtp pruning 启用vtp修解
switch(config)#no vtp pruning 关闭vtp修解
注:要想从vtp中减少一台交换机只需将该交换机vtp 名更改
Cisco交换机命令之生成树stp:
switch(config)#spanning-tree vlan 启用stp生成树(基于vlan)
switch(config)#spanning-tree vlan root primary 指定根交换机(基于vlan)
switch(config)#spanning-tree vlan root secondary 指定备用根交换机(基于vlan)
switch(config)#spanning-tree vlan priority 指定交换机优先级(基于vlan)
switch(config)#no spanning-tree vlan priority 将交换机的优先级恢复默认值(基于vlan)
switch(config-if)#spanning-tree vlan cost 指定端口成本(起用trunk的端口模式下)
switch(config-if)#spanning-tree vlan port-prioty 指定交换机端口优先级(基于vlan)
switch(config-if)#spanning-tree portfast 配置速端口(连接终端设备的端口状态)如pc机
switch(config)#spanning-tree uplinkfast 配置上行速端口
switch(config)#spanning-tree vlan hello-time 配置交换机hello时间(基于vlan)
switch(config)#spanning-tree vlan forward-time 修改转发延迟计时器(基于vlan)
switch(config)#spanning-tree vlan max-time 修改最大老化时间(基于vlan)
switch#show spanning-tree summery 检测vlan生成树配置
switch#show spanning-tree vlan detail 浏览详细生成树配置信息
switch#show spanning-tree interface detail 浏览详细生成树端口配置信息
Cisco交换机命令之交换机显示命令:
switch#show vtp status 查看vtp配置信息
switch#show running-config 查看当前配置信息
switch#show vlan 查看vlan配置信息
switch#show interface 查看端口信息
switch#show int f0/0 查看指定端口信息
switch#dir flash: 查看闪存
switch#show version 查看当前版本信息
switch#show mac-address-table aging-time 查看mac超时时间
switch#show cdp cisco设备发现协议 (可以查看聆接设备)
switch#show cdp traffic 杳看接收和发送的cdp包统计信息
switch#show cdp neighbors 查看与该设备相邻的cisco设备
switch#show interface f0/1 switchport 查看有关switchport的配置
switch#show cdp neighbors 查看与该设备相邻的cisco设备